{
  "@id": "urn:uuid:c0e95f39-4154-410a-bfe9-2f8425e68684",
  "role": "Document Creator",
  "author": "https://tuxcare.com",
  "version": 2,
  "@context": "https://openvex.dev/ns/v0.2.0",
  "timestamp": "2026-10-27T11:08:28.980217+00:00",
  "statements": [
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:pypi/lxml@4.9.4.post1+tuxcare",
          "identifiers": {
            "purl": "pkg:pypi/lxml@4.9.4.post1+tuxcare"
          }
        }
      ],
      "timestamp": "2026-10-27T11:08:28.980217+00:00",
      "status_notes": "Vulnerability CVE-2022-2309 does not affect version 4.9.4.post1+tuxcare of lxml. CVE-2022-2309 (GHSA-wrxv-2j5q-m38w) affects lxml < 4.9.1 and was fixed upstream in 4.9.1 by 86368e9c; 4.9.4 is outside the affected range. Verified 27.10: iterwalk/c14n NULL-deref PoC segfaults vanilla lxml 4.9.0 and does not affect vanilla 4.9.4 or 4.9.4.post1+tuxcare (libxml2 2.10.3).",
      "justification": "vulnerable_code_not_present",
      "vulnerability": {
        "name": "CVE-2022-2309"
      },
      "impact_statement": "CVE-2022-2309 (GHSA-wrxv-2j5q-m38w) affects lxml < 4.9.1 and was fixed upstream in 4.9.1 by 86368e9c; 4.9.4 is outside the affected range. Verified 27.10: iterwalk/c14n NULL-deref PoC segfaults vanilla lxml 4.9.0 and does not affect vanilla 4.9.4 or 4.9.4.post1+tuxcare (libxml2 2.10.3)."
    },
    {
      "status": "fixed",
      "products": [
        {
          "@id": "pkg:pypi/lxml@4.9.4.post1+tuxcare",
          "identifiers": {
            "purl": "pkg:pypi/lxml@4.9.4.post1+tuxcare"
          }
        }
      ],
      "timestamp": "2026-09-24T09:31:26.931840+00:00",
      "status_notes": "Vulnerability CVE-2026-41066 is fixed in version 4.9.4.post1+tuxcare of lxml.",
      "vulnerability": {
        "name": "CVE-2026-41066"
      }
    }
  ]
}
