{
  "@id": "urn:uuid:4f3863d2-8cbf-4b8f-b1c2-5ced614e26c3",
  "role": "Document Creator",
  "author": "https://tuxcare.com",
  "version": 2,
  "@context": "https://openvex.dev/ns/v0.2.0",
  "timestamp": "2026-10-10T10:05:00.159654+00:00",
  "statements": [
    {
      "status": "fixed",
      "products": [
        {
          "@id": "pkg:npm/qs@6.4.3-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.4.3-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-10T10:05:00.159654+00:00",
      "status_notes": "Vulnerability CVE-2025-15284 is fixed in version 6.4.3-tuxcare.2 of qs.",
      "vulnerability": {
        "name": "CVE-2025-15284"
      }
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.4.3-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.4.3-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-10T10:04:00.071644+00:00",
      "status_notes": "Vulnerability CVE-2026-2391 does not affect version 6.4.3-tuxcare.2 of qs. not_affected \u2014 Version 6.4.3 is not affected by CVE-2026-2391. The vulnerability requires the 'comma' parsing option, which was introduced in v6.10.0+ (2018-09-09) and does not exist in the 6.4.x maintenance branch. Without comma-parsing functionality, the attack chain cannot be established.",
      "justification": "vulnerable_code_not_present",
      "vulnerability": {
        "name": "CVE-2026-2391"
      },
      "impact_statement": "not_affected \u2014 Version 6.4.3 is not affected by CVE-2026-2391. The vulnerability requires the 'comma' parsing option, which was introduced in v6.10.0+ (2018-09-09) and does not exist in the 6.4.x maintenance branch. Without comma-parsing functionality, the attack chain cannot be established."
    },
    {
      "status": "fixed",
      "products": [
        {
          "@id": "pkg:npm/qs@6.4.3-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.4.3-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-10T10:04:00.071644+00:00",
      "status_notes": "Vulnerability CVE-2026-82417 is fixed in version 6.4.3-tuxcare.2 of qs.",
      "vulnerability": {
        "name": "CVE-2026-82417"
      }
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.4.3-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.4.3-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-10T10:04:00.071644+00:00",
      "status_notes": "Vulnerability CVE-2026-82562 does not affect version 6.4.3-tuxcare.2 of qs. not_affected \u2014 The target version (qs 6.4.3) does not have the vulnerable code pattern. The vulnerability (CVE-2026-82562) requires the `comma: true` parsing option to enable processing of comma-separated values in query string parameters. This feature was introduced in v6.7.0 (commit b84acba, September 2018), after the target version 6.4.3. The target does not process comma-separated values at all and lacks ...",
      "justification": "vulnerable_code_not_present",
      "vulnerability": {
        "name": "CVE-2026-82562"
      },
      "impact_statement": "not_affected \u2014 The target version (qs 6.4.3) does not have the vulnerable code pattern. The vulnerability (CVE-2026-82562) requires the `comma: true` parsing option to enable processing of comma-separated values in query string parameters. This feature was introduced in v6.7.0 (commit b84acba, September 2018), after the target version 6.4.3. The target does not process comma-separated values at all and lacks ..."
    },
    {
      "status": "not_affected",
      "products": [
        {
          "@id": "pkg:npm/qs@6.4.3-tuxcare.2",
          "identifiers": {
            "purl": "pkg:npm/qs@6.4.3-tuxcare.2"
          }
        }
      ],
      "timestamp": "2026-10-10T10:04:00.071644+00:00",
      "status_notes": "Vulnerability CVE-2026-8723 does not affect version 6.4.3-tuxcare.2 of qs. not_affected \u2014 Version 6.4.3 is not affected by CVE-2026-8723. The vulnerability requires the comma arrayFormat feature combined with encodeValuesOnly:true, but the comma arrayFormat was introduced later in v6.11.1 (commit 4c4b23d). Version 6.4.3 only supports 'indices', 'brackets', and 'repeat' array formats. When arrayFormat:'comma' is specified, it falls back to 'indices' format which processes arrays recu...",
      "justification": "vulnerable_code_not_present",
      "vulnerability": {
        "name": "CVE-2026-8723"
      },
      "impact_statement": "not_affected \u2014 Version 6.4.3 is not affected by CVE-2026-8723. The vulnerability requires the comma arrayFormat feature combined with encodeValuesOnly:true, but the comma arrayFormat was introduced later in v6.11.1 (commit 4c4b23d). Version 6.4.3 only supports 'indices', 'brackets', and 'repeat' array formats. When arrayFormat:'comma' is specified, it falls back to 'indices' format which processes arrays recu..."
    }
  ]
}
